Seas0nPass Cuts the Cord for 4.4.4

Happy New Year! Today we are happy to release an updated version of Seas0nPass that supports an untethered jailbreak of the latest 4.4.4 (iOS 5.0.1) AppleTV software. Big thanks goes to the world famous @pod2g for doing the lion's share of the work to make this new version possible.

What's new in AppleTV 4.4.4?

  • AirPlay Mirroring: Now with video mirroring – wirelessly stream what’s on your iPad 2 screen to your HDTV.
  • Photo Stream: View photos recently taken on your iOS device and pushed to your Photo Stream in iCloud.
  • Trailers: A whole new way to browse and view hundreds of the latest theatrical trailers.
  • National Hockey League: Watch live games. View highlights, scores, and more.
  • Wall Street Journal Live: Watch up-to-date news, business commentary, and financial analysis from leading experts.
  • Audio output: Addresses an issue in which audio may not play through the optical port when the TV is turned off.
  • Netflix: Added support for Netflix in Mexico and Latin America.
  • Stability and performance: version 4.4.4 includes general performance and stability improvements, including a fix for an issue that displayed an error when playing some video content.

Note: If you're already running a tethered version of 4.4.4 you will need to re-jailbreak using Seas0nPass to take advantage of the new untethered version. 

Which plugins are supported on 4.4.4?

  • Couch Surfer (works)
  • Last.fm (works)
  • Media Player (works)
  • NitoTV (works)
  • Overflow (works)
  • Plex (works)
  • Remote HD (works)
  • Rowmote (works)
  • RSS Feeds (works)
  • Weather (works)
  • XBMC (works)

How do I get it?

As always, Seas0nPass is available as a free download from Seas0nPass.com.

Troubleshooting tips can be found here.

Enjoy :-)

Comments

So I checked everything except....where the problem really was. It was a loose speaker wire. No actual issue with the Apple tv, I must have loosened the connection when I removed the ATv from the cabinet. I replaced the loose wire and sound is good to go. My apologies.

My only issue now is XBMC won't instal, but I suspect that's a result of XBMC.org currently being down. I'll wait for the site to be up before trying again.

Im getting Error Code (9) when iTunes try's to restore.. Anyone know how to fix this ? Thanks

Got the same error. Worked for me, after I made sure no other iOS devices are connected. You will have to put an iPhone or iPad into Airplane mode, if you use wireless syncing…

iTunes has some crazy errors I was getting error 2 and it was because of my firewall I had on. But after fixing that I started getting error 1600. If you are getting errors that are not 1600 or 1300 then there is something else that is messing with your iTunes restore. Try using another pc or turn off your firewall

I cannot get the apple tv to enter DFU mode; when I connect it to my windows 7 computer, it chimes, but the light on the front of the apple tv does not flash. Nothing I do allows it to be recognized by seasonpass

just connect the power cord and then hold power+down then when it starts to flicker fast real ease and then rite away hold menu and play

That doesn't work for me. What do you mean by power+down? Is it Menu+down?

Menu+down makes ATV flicker real fast, but as soon as I release them to press menu+play it stops flickering and nothing happens.

thank you, that worked.

A detail that needs to be added is that the ATV needs to be connected to the network. I set mine up with a wired ethernet connection and the jailbreak failed each and every time when the device was not connected to the network. Once I connected the device to the network, the jailbreak was flawless.

I realized that pictures played in Media Player look far worse than the same pictures played in XBMC.

Anyone else here having the same problem?

I wouldn't even screw around with the firecore media player. It has a lot of issues (buffering, only SMB sharing, crappy pictures) and you can run the same things in XBMC. You can also use home sharing to show your pictures in high quality. No syncing or anything, just go into iTunes and tell it what folders to use.

I actually like media player a lot because it right under the main menu. I can set up short cuts to my folders on my Mac and external hard drive which are just two clicks away. for pictures I just uses apples photo stream or aperture from my Mac. As far as movies playing I never get any lags

No joy.

Brand-new ATV 2 with 4.4.2
iTunes 10.5.2 on MacBook with Snow Leopard.
Seas0nPass downloads the 4.4.4 IPSW and works it's magic. When instructed to, I connect the USB cable and hold down the buttons on remote. After 7 seconds, the LED starts flashing quickly. I release the buttons.
Nothing happens. -- iTunes doesn't open. No restore takes place.

If I manually launch iTunes, it sees the ATV is connected, but I have no idea what to do next.

Kyphos, try unplugging the ATV from the electrical outlet and just leave it connected to your computer via the USB connection. This worked for me.

@chrish,
My ATV2 was not connected to power. I followed the step-by-step guide and only had it connected to the Mac with micro-USB. No power, no HDMI, no ethernet.
But thanks for the suggestion.

I've just tried rebooting my MacBook and went through the procedure again. Same result -- iTunes doesn't open after releasing the buttons on the remote.

-kyphos

U GOT IT YET???

Sometimes the script fails u have to manually select the custom firmware that seasonpass creates

@james,
I've been thinking something like that might be the workaround, but I don't know how to do it. I've searched my HD and discovered where seas0npass stored the modified IPSW firmware. But then what? Do I launch iTunes manually? Does Seas0npass need to keep running so it can fake out the signing of the blobs?

As you can deduce, the jailbreaking thing is all black magic to me.

Thanks a lot for your help.

Kyphos Are you getting the 'New Hardware Detected' or 'Installing New Hardware' message when you first connect the ATV to your PC. If not try connecting the ATV to a different USB port on the PC. When you connect the ATV to the pc you should have some kind of message that the PC has detected the ATV, make sure of that first then disconnect the ATV and run Seasonpass and reconnect after the 7 second button press stage.

Also try a different USB lead as the one you might by using to connect the ATV to the PC could be faulty

@sjstimer,
Thanks for the response.
I'm using a Mac w/ OSX 10.6.8, hence there's no 'new hardware detected' message when connecting the ATV. (OSX does not issue such notifications when USB devices are hot-plugged).

However, I've confirmed that the ATV is seen by OSX. When I connect the USB cable with the ATV connected to 110 VAC, the ATV is detected and iTunes automatically launches. The ATV is listed in the sidebar. If I wanted to, I could click RESTORE and do a conventional Apple firmware restore.

I've googled this problem, and read all the tips and techniques posted here. I finally found a recipe that worked :-)
When Seas0npass instructed me to do so, I plugged in the USB cable, then pressed Menu/Play for 7 seconds. The LED on the ATV started flashing, but nothing else happened. No DUF and no iTunes. So I momentarily connected it to the AC power, then did the 7-second button push again. Eureka, Seas0npass finally reported it was in DFU mode. I yanked the power cord out, and the process completed without further problems. After iTunes reported that the 'restore to factory settings' was complete, I unplugged the USB cable, connected power and HDMI, and let it boot up. Then connected ethernet cable when it asked about joining a wireless network.

My ATV now displays the red FC logo in the lower-right corner.I had to reconfigure the ATV from scratch (time zone, AppleID, etc), but it now seems to be working just fine. Next stop - ATV Flash Black.

Thanks to the Firecore and Seas0npass community for the great software, and the debugging tips.
Happy New Year.

I too am having a problem: I get a 'itunes restore script failed' message. I do see the IPSW in the finder. Can I finish the process without Seas0nPass? Or do I need to do something differently? I have jailbroken before without incident. Latest versions of everything and followed step-by-step.

I have solved this problem. The solution is that when the script fails, you go into iTunes, hold the 'Option' key and click the restore button beside the TV which will allow you to select the IPSW that has been altered by Seas0nPass. Just run the update and you're fine.

what featues does this add? i beleive it did it correctly? i have the FC logo on bottum right corner but i dont see any diff... did i miss something here? should i be purchasing aTV black?

thanks

You can install XBMC once your ATV is jailbroken. That is the mother of all reasons to jailbreak it :)

http://lifehacker.com/5739364/how-to-install-xbmc-on-your-apple-tv-2

mikeyags, you need to purchase and install aTV black to see new features in the menu. Seas0nPass only performs the jailbreak.

My Solution for "This device isn't eligible for the requested build."

Tried to untether my tethered jailbroken ATV2 4.4.4. I used Seas0npass with my macbook and itunes 10.5.2 and always got this error "This device isn't eligible for the requested build".

I tried to restore via itunes without Seas0npass and also got this error!!

The last thing I could imagine was the itunes version. So I tried the same using my Windows 7 Bootcamp with itunes 10.5.0 installed. It worked like a charm and now my ATV2 is untethered jailbroken with 4.4.4 on it.

Hope it helps.

Greetz

acid

I was having this error. Turns out since had downloaded the previous seasonpass it was trying to install the older firmware. In seasonpass go to preferences and make sure 4.4.4 is selected. This worked for me.

I'm having the same issues with my Mac. I will try the windows bootcamp method

Happy New Year @ ALL

I have a Problem: I start Seas0nPass and hold "shift" (windows pc) and click Create IPSW
and use AppleTV2,1_4.4.4_9A406a_Restore.ipsw then Seas0nPass hangUp (return to desktop) :(

i can not load the ipsw over Seas0nPass.. it is loading and loading.. many hours.

You can Help me?

(i use Windows 7 / 64Bit / iTunes 10.5.2)

Thank you!

luv the updates... hate the weather... can u guy change the weather back to the way it was... that display was the main reason i brought it... i was one of the first to buy it and that weather made it stand out... plz change that back.... thankssssss...

OOPS I FOUND IT

Thank you FC!
Two atv's smoothly jailbreaked.

Be sure to use a right usb-cable! Thought the 1st one was a good one, but after xx attempts it wasn't. Tried a 2nd one and all went well.

Sorry for this question, but what is the right USB-Cable? I'm using a USB Nokia CA 101 http://www.amazon.com/Nokia-CA-101-Cellular-phone-cable/dp/B000U6QPFI/re... and it won't work!

BTStack don't work 4.4.4
connecting.....wait wait....

It works. Thank you FireCore

Instructions how to get PLEX (0.9.0 beta 4) on a Jailbreaked Apple TV 2 (4.4.4) [UPDATE from earlyer post]

Be sure your Apple TV2 is on

1) Start Terminal on your iMac
2) Type: ssh root@apple-tv.local3) Type: alpine (the password)
4) Type: echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
5) Type: apt-get remove com.plex.client-plugin
6) Type: apt-get update
7) Type: apt-get install com.plex.client-plugin=0.0.9.0.0-312c11b0

Now your Apple TV2 should reset and when its starters there is PLEX.

Tip a) in stead of 2) Type: ssh root@apple-tv.local you can use 2) Type: ssh root@your IP of the Apple TV2 (eg. 192.168.1.75)

and

Tip b) It is possible you get some errors in Terminal like " cant find ....." then maybe you have to do the instructions 2-times , just do it !

Press Yes or Y when Terminal ask for that.

(hint: you can also copy => paste the lines in terminal)

suc6

Happy New Year for Everybody

iFred

First time trying to jailbreak. Did it no problem, first time. Got Plex on in 2 tries, about 10 mins using these instructions. Thanks!!

thanks fired

plex is working but some films can't play some frozen at begin some did not start and big problem about subs all are mirror on my local language .is there any solution for the subs ?

thanks, it worked in first try. :) cheers

PLEX is back! Thanks!!!

PLEX is back! Thanks!!!

installed season pass on apple tv 2, worked, no problem. installed aTV black, said it was successful but now after the apple logo all I get is a blue screen. after minutes it just goes back to the apple logo and blue screen again. so, pretty much fucked up here

BTStack don't work 4.4.4
connecting.....wait wait....

Connected my keyboard no problems on 4.4.4

I've got the same problem. Bluetooth devices are found but no connect even after 5 minutes.

Any suggestions?

Happy New Year to Firecore Team & all users ,-)

not connect btstack

I got an error in iTunes as well but when I plugged in the hdmi cable and removed the USB cable it showed the fc symbol and I was jail broken
I installed xbmc, nitotv everything works great . Only problem I have is ice films keeps pausing waiting for the movie to download. It must be mega upload because I'm not a member so slow download

I've been able to JB my aTV2 to 4.4.4

1. Resolve 3194 restore problem

http://jaxov.com/2011/05/fix-itunes-error-3194-21-1013-1014-1015-while-resorting-ios-4-3-3-stock-or-custom-ipsw/

2. Use iREB R4 (download from: http://oron.com/9d0ns5rggw9v) (http://ih8sn0w.com/index.php/products/view/ireb.snow) to put aTV2 into pwned DFU

Full video instruction here: (http://www.youtube.com/watch?v=Bstb_GpyIoc)

Happy New Year!!!! ......my first New Year accomplishment.....

hope this will help some of you out there having the same problem

would plex work as it say only 0.9.0 beta only can someone please confirm it works as i bought aTV for this reason

Installed yesterday went very smooth just can't wait for the new plex to come out. Thanks again

Im having hard time getting logged in to web site. I even ask for New pw and they sent me a link for a 1 time log in but that doesnt even work

© 2014 FireCore, LLC. All Rights Reserved.

Terms | Privacy